[Tiki-devel] Updating Tablesorter

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Tiki-devel] Updating Tablesorter

lindon-4
I tried to update tablesorter to version 2.28.9 by changing composer.json and running temp/composer.phar, but I get the following error message:

Problem 1
    - Installation request for mottie/tablesorter ^2.28.9 -> satisfiable by mottie/tablesorter[v2.28.9].
    - mottie/tablesorter v2.28.9 requires jquery ^1.2.6 -> no matching package found.

How do I resolve this?
Thanks,
lindon
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Tiki-devel] Updating Tablesorter

Jonny Bradley-4
Hi Lindon,

Hmm, i think that's presumably because we're on jQuery 3.x and the caret operator on ^1.2.6 means all versions of jQuery up to (but less than) 2.0.0, according to https://getcomposer.org/doc/articles/versions.md#caret

So it looks like they have the wrong operator on that if, presumably, they mean any version greater than 1.2.6, i.e. they should be using >=1.2.6 (in here https://github.com/Mottie/tablesorter/blob/v2.28.9/composer.json)

Does that sound possible? If so i guess any other users of tablesorter via composer will also be stuck...

Any other ideas? Could it be something else?

jonny




> On 10 May 2017, at 02:23, lindon <[hidden email]> wrote:
>
> I tried to update tablesorter to version 2.28.9 by changing composer.json and running temp/composer.phar, but I get the following error message:
>
> Problem 1
>    - Installation request for mottie/tablesorter ^2.28.9 -> satisfiable by mottie/tablesorter[v2.28.9].
>    - mottie/tablesorter v2.28.9 requires jquery ^1.2.6 -> no matching package found.
>
> How do I resolve this?
> Thanks,
> lindon
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Tiki-devel] Updating Tablesorter

lindon-4
Many thanks Jonny for taking a look. I’ve submitted an issue to the project to see if what you pointed out could be the issue.
Thanks,
lindon


> On May 10, 2017, at 5:48 AM, Jonny Bradley <[hidden email]> wrote:
>
> Hi Lindon,
>
> Hmm, i think that's presumably because we're on jQuery 3.x and the caret operator on ^1.2.6 means all versions of jQuery up to (but less than) 2.0.0, according to https://getcomposer.org/doc/articles/versions.md#caret
>
> So it looks like they have the wrong operator on that if, presumably, they mean any version greater than 1.2.6, i.e. they should be using >=1.2.6 (in here https://github.com/Mottie/tablesorter/blob/v2.28.9/composer.json)
>
> Does that sound possible? If so i guess any other users of tablesorter via composer will also be stuck...
>
> Any other ideas? Could it be something else?
>
> jonny
>
>
>
>
>> On 10 May 2017, at 02:23, lindon <[hidden email]> wrote:
>>
>> I tried to update tablesorter to version 2.28.9 by changing composer.json and running temp/composer.phar, but I get the following error message:
>>
>> Problem 1
>>   - Installation request for mottie/tablesorter ^2.28.9 -> satisfiable by mottie/tablesorter[v2.28.9].
>>   - mottie/tablesorter v2.28.9 requires jquery ^1.2.6 -> no matching package found.
>>
>> How do I resolve this?
>> Thanks,
>> lindon
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> TikiWiki-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>>
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel