Quantcast

[Tiki-devel] Title site setting, logic or... ?

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Tiki-devel] Title site setting, logic or... ?

Bernard Sfez-3
Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Jonny Bradley-4
Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



> On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:
>
> Hello,
>
> On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
> "My Website"
>
> By default Tiki display the website + site location:
> "My Website | Homepage"
>
> So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
> There is a parameter Site title location with options, Before, After, None.
>
> Logic says: if you select none, location won’t be displayed.
> But this is not working. Location (Homepage) is always displayed.
>
>
> But logic is wrong or there is a bug here ? :)
>
> Bernard Sfez | bsfez.com
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Bernard Sfez-3
Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Jean-Marc Libs
+1 and -1 :-D

I believe this is the result of inconsistent labels.

On Mon, Apr 3, 2017 at 6:28 AM, Bernard Sfez <[hidden email]> wrote:
Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In the general settings page, it is called "Browser title = My Website", then just below, there is the confusingly named drop-down called "Site title location".
It all makes sense when you rename it as "Browser title location".
So, -1 to the change in behaviour, we only need a "[UX] make labels consistent" change here.
 

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

No it does not. I see in trunk and in 12.x and in 15.x:
Site title location After: Homepage | My Website
Site title location Before: My Website | Homepage
Site title location None: Homepage

Which would make perfect sense if it was labelled "Browser title location"
 

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

+1 to the following:
Browser title location None: Homepage
Browser title location Only : My Website

Cheers,
J-M
 

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)

hehe. I remember simply fixing the indentation without any functional change was a pain.
 


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Jonny Bradley-4
In reply to this post by Bernard Sfez-3
Hi Bernard

On my tiki the pref is called "Site title location" not "Site location" (should be Site Title Location, but that's another story ;) so when it's set to "none" the site title should not be displayed, which is what happens.

For me (in 17.x of course) it's not how you describe in either block below, it's the other way round. I get:

Site title location After:     Homepage | My Website
Site title location Before:   My Website | Homepage
Site title location None:     Homepage

It's been like this since Tiki 1.x i think so i really don't think rewording it and changing the behaviour now would be a good idea.

HTH

jonny

p.s. I believe the default should be After as most sites and SEO people seem to agree is best practice, e.g. wikipedia, google, bbc etc etc.


On 3 Apr 2017, at 05:28, Bernard Sfez <[hidden email]> wrote:

Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Jonny Bradley-4
In reply to this post by Jean-Marc Libs

On 3 Apr 2017, at 11:48, Jean-Marc Libs <[hidden email]> wrote:

+1 and -1 :-D

Exactly :)


I believe this is the result of inconsistent labels.

On Mon, Apr 3, 2017 at 6:28 AM, Bernard Sfez <[hidden email]> wrote:
Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In the general settings page, it is called "Browser title = My Website", then just below, there is the confusingly named drop-down called "Site title location".
It all makes sense when you rename it as "Browser title location".
So, -1 to the change in behaviour, we only need a "[UX] make labels consistent" change here.
 

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

No it does not. I see in trunk and in 12.x and in 15.x:
Site title location After: Homepage | My Website
Site title location Before: My Website | Homepage
Site title location None: Homepage

Which would make perfect sense if it was labelled "Browser title location"
 

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

+1 to the following:
Browser title location None: Homepage
Browser title location Only : My Website

Cheers,
J-M
 

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)

hehe. I remember simply fixing the indentation without any functional change was a pain.
 


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

luciash d' being
In reply to this post by Jonny Bradley-4

+1 Jonny :) Bernard lost the "title" in translation it seems? I was totally confused for couple of minutes by your explanation Bernie, then it started to give sense when I re-read properly, then jonny killed it again and the World is as it be should again ;)

luci


On 04/03/2017 12:53 PM, Jonny Bradley wrote:
Hi Bernard

On my tiki the pref is called "Site title location" not "Site location" (should be Site Title Location, but that's another story ;) so when it's set to "none" the site title should not be displayed, which is what happens.

For me (in 17.x of course) it's not how you describe in either block below, it's the other way round. I get:

Site title location After:     Homepage | My Website
Site title location Before:   My Website | Homepage
Site title location None:     Homepage

It's been like this since Tiki 1.x i think so i really don't think rewording it and changing the behaviour now would be a good idea.

HTH

jonny

p.s. I believe the default should be After as most sites and SEO people seem to agree is best practice, e.g. wikipedia, google, bbc etc etc.


On 3 Apr 2017, at 05:28, Bernard Sfez <[hidden email]> wrote:

Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot


_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Torsten Fabricius-4
In reply to this post by Jean-Marc Libs
Hello,

I +1 Jean-Marc suggestion, as imho it is indeed the location of the site title in the Browser.

And we could add an Only option, so +1 to this part of Bernards initial request

For clarification as I see it, it would be:

either

Browser Title location After: Homepage | My Website
Browser Title location Before: My Website | Homepage
Browser Tiitle location None: Homepage
Browser Title location Only : My Website

or

Browser Site Title location After: Homepage | My Website
Browser Site Title location Before: My Website | Homepage
Browser Site Tiitle location None: Homepage
Browser Site Title location Only : My Website

Regards,
Torsten

On 03.04.2017 12:48, Jean-Marc Libs wrote:
+1 and -1 :-D

I believe this is the result of inconsistent labels.

On Mon, Apr 3, 2017 at 6:28 AM, Bernard Sfez <[hidden email]> wrote:
Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In the general settings page, it is called "Browser title = My Website", then just below, there is the confusingly named drop-down called "Site title location".
It all makes sense when you rename it as "Browser title location".
So, -1 to the change in behaviour, we only need a "[UX] make labels consistent" change here.
 

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

No it does not. I see in trunk and in 12.x and in 15.x:
Site title location After: Homepage | My Website
Site title location Before: My Website | Homepage
Site title location None: Homepage

Which would make perfect sense if it was labelled "Browser title location"
 

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

+1 to the following:
Browser title location None: Homepage
Browser title location Only : My Website

Cheers,
J-M
 

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)

hehe. I remember simply fixing the indentation without any functional change was a pain.
 


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot


_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Title site setting, logic or... ?

Bernard Sfez-3
In reply to this post by Jonny Bradley-4
I read you Jonny, but no matter how we improve the words, Tiki is actually set so everybody HAVE to display the location (Homepage). (before or after or alone)
But that’s not fine with me. I want Tiki to display my website title alone without any location.

A pretty basic common thing that do (by default) any of our competitors.

It sound to me dull, we force Tiki to display the location no matter what’s the reason.


On 3 Apr 2017, at 13:53 , Jonny Bradley <[hidden email]> wrote:

Hi Bernard

On my tiki the pref is called "Site title location" not "Site location" (should be Site Title Location, but that's another story ;) so when it's set to "none" the site title should not be displayed, which is what happens.

For me (in 17.x of course) it's not how you describe in either block below, it's the other way round. I get:

Site title location After:     Homepage | My Website
Site title location Before:   My Website | Homepage
Site title location None:     Homepage

It's been like this since Tiki 1.x i think so i really don't think rewording it and changing the behaviour now would be a good idea.

HTH

jonny

p.s. I believe the default should be After as most sites and SEO people seem to agree is best practice, e.g. wikipedia, google, bbc etc etc.


On 3 Apr 2017, at 05:28, Bernard Sfez <[hidden email]> wrote:

Hi J,

Site location (the page where I’m on) = HomePage
Site title = My Website

In trunk is working that way:

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: Homepage

This is totally confusing and wrong. It should be more like;

Site location After: My Website | Homepage
Site location Before: Homepage | My Website
Site Location None: My Website
Site Location Only : Homepage

Wording may be improved but does that make sense that way ?

If yes, I did a fix already on my local and it work just fine.

B

PS : (Agree about header.tpl… will be a task for Tiki18 ) :)


On 2 Apr 2017, at 16:31 , Jonny Bradley <[hidden email]> wrote:

Hi B

Looks like it works fine for me in trunk - but it's the wrong way round for you i guess - setting it to none means i get just the wiki page, or admin panel name as the browser title as expected.

Hmm, i had a look at adding an "Only" option, but header.tpl is such a mess that it would be hard to add that cleanly, sorry.

Another time maybe (we really need to move the logic in header,tpl into php i reckon, it's out of control as it is)

jonny



On 2 Apr 2017, at 08:32, Bernard Sfez <[hidden email]> wrote:

Hello,

On a Tiki 16.x I want to display as title of the website (browser tab or facebook title) ONLY the website title:
"My Website"

By default Tiki display the website + site location:
"My Website | Homepage"

So I check how to remove site location at : /tiki-admin.php?page=general => Site Identity
There is a parameter Site title location with options, Before, After, None.

Logic says: if you select none, location won’t be displayed.
But this is not working. Location (Homepage) is always displayed.


But logic is wrong or there is a bug here ? :)

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Loading...