[Tiki-devel] Problem with page aliases (at doc.t.o)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Tiki-devel] Problem with page aliases (at doc.t.o)

Gary Cunningham-Lee
Hi,

At https://doc.tiki.org/Tiki17, the syntax for the page aliases looks
like this:

(alias(Tiki17.0)) | (alias(TikiWiki17)) | (alias(TikiWiki17.0)) |
(alias(TikiWiki 17.0)) | (alias(TikiWiki 17)) | (alias(Tiki 17)) |
(alias(Tiki 17.0))

so all of them have the same syntax, but when the page displays, the
last three items have the "Create this page" link color and tooltip
message. Any idea why these three aren't recognized as aliases?

-- Gary

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Problem with page aliases (at doc.t.o)

luciash d' being
Hmm, that is really a mystery to me! :-o

No idea Gary, sorry.

luci


On 28.7.2017 6:19, Gary Cunningham-Lee wrote:

> Hi,
>
> At https://doc.tiki.org/Tiki17, the syntax for the page aliases looks
> like this:
>
> (alias(Tiki17.0)) | (alias(TikiWiki17)) | (alias(TikiWiki17.0)) |
> (alias(TikiWiki 17.0)) | (alias(TikiWiki 17)) | (alias(Tiki 17)) |
> (alias(Tiki 17.0))
>
> so all of them have the same syntax, but when the page displays, the
> last three items have the "Create this page" link color and tooltip
> message. Any idea why these three aren't recognized as aliases?
>
> -- Gary
>
> ------------------------------------------------------------------------------
>
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Problem with page aliases (at doc.t.o)

Gary Cunningham-Lee
On a whim, I removed the non-functioning aliases and saved the page,
then added them back and saved again, and now they work ok. Maybe there
was some temporary weirdness when they were input the first time.

On 7/28/2017 3:47 PM, luciash wrote:

> Hmm, that is really a mystery to me! :-o
>
> No idea Gary, sorry.
>
> luci
>
>
> On 28.7.2017 6:19, Gary Cunningham-Lee wrote:
>> Hi,
>>
>> At https://doc.tiki.org/Tiki17, the syntax for the page aliases looks
>> like this:
>>
>> (alias(Tiki17.0)) | (alias(TikiWiki17)) | (alias(TikiWiki17.0)) |
>> (alias(TikiWiki 17.0)) | (alias(TikiWiki 17)) | (alias(Tiki 17)) |
>> (alias(Tiki 17.0))
>>
>> so all of them have the same syntax, but when the page displays, the
>> last three items have the "Create this page" link color and tooltip
>> message. Any idea why these three aren't recognized as aliases?
>>
>> -- Gary
>>
>> ------------------------------------------------------------------------------
>>
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> TikiWiki-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>
>
> ------------------------------------------------------------------------------
>
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Problem with page aliases (at doc.t.o)

Jonny Bradley-4
The last three have spaces in them so must have something to do with the change from spaces to dashes in the sefurl processing.

Looks like these need regenerating too when that changes...

jonny

> On 28 Jul 2017, at 08:53, Gary Cunningham-Lee <[hidden email]> wrote:
>
> On a whim, I removed the non-functioning aliases and saved the page, then added them back and saved again, and now they work ok. Maybe there was some temporary weirdness when they were input the first time.
>
> On 7/28/2017 3:47 PM, luciash wrote:
>> Hmm, that is really a mystery to me! :-o
>> No idea Gary, sorry.
>> luci
>>> On 28.7.2017 6:19, Gary Cunningham-Lee wrote:
>>> Hi,
>>>
>>> At https://doc.tiki.org/Tiki17, the syntax for the page aliases looks like this:
>>>
>>> (alias(Tiki17.0)) | (alias(TikiWiki17)) | (alias(TikiWiki17.0)) | (alias(TikiWiki 17.0)) | (alias(TikiWiki 17)) | (alias(Tiki 17)) | (alias(Tiki 17.0))
>>>
>>> so all of them have the same syntax, but when the page displays, the last three items have the "Create this page" link color and tooltip message. Any idea why these three aren't recognized as aliases?
>>>
>>> -- Gary
>>>
>>> ------------------------------------------------------------------------------
>>> Check out the vibrant tech community on one of the world's most
>>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>> _______________________________________________
>>> TikiWiki-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>> ------------------------------------------------------------------------------ Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> TikiWiki-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Problem with page aliases (at doc.t.o)

luciash d' being
Hmm, Jonny, not sure, the fourth one also had spaces: "(alias(TikiWiki
17.0))".

But glad it got fixed by Gary somehow ;)

luci


On 28.7.2017 10:26, Jonny Bradley wrote:

> The last three have spaces in them so must have something to do with the change from spaces to dashes in the sefurl processing.
>
> Looks like these need regenerating too when that changes...
>
> jonny
>
>> On 28 Jul 2017, at 08:53, Gary Cunningham-Lee <[hidden email]> wrote:
>>
>> On a whim, I removed the non-functioning aliases and saved the page, then added them back and saved again, and now they work ok. Maybe there was some temporary weirdness when they were input the first time.
>>
>> On 7/28/2017 3:47 PM, luciash wrote:
>>> Hmm, that is really a mystery to me! :-o
>>> No idea Gary, sorry.
>>> luci
>>>> On 28.7.2017 6:19, Gary Cunningham-Lee wrote:
>>>> Hi,
>>>>
>>>> At https://doc.tiki.org/Tiki17, the syntax for the page aliases looks like this:
>>>>
>>>> (alias(Tiki17.0)) | (alias(TikiWiki17)) | (alias(TikiWiki17.0)) | (alias(TikiWiki 17.0)) | (alias(TikiWiki 17)) | (alias(Tiki 17)) | (alias(Tiki 17.0))
>>>>
>>>> so all of them have the same syntax, but when the page displays, the last three items have the "Create this page" link color and tooltip message. Any idea why these three aren't recognized as aliases?
>>>>
>>>> -- Gary
>>>>
>>>> ------------------------------------------------------------------------------
>>>> Check out the vibrant tech community on one of the world's most
>>>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>>> _______________________________________________
>>>> TikiWiki-devel mailing list
>>>> [hidden email]
>>>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>>> ------------------------------------------------------------------------------ Check out the vibrant tech community on one of the world's most
>>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>> _______________________________________________
>>> TikiWiki-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> TikiWiki-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Loading...