[Tiki-devel] PHP 7.1 as a minimum requirement for Tiki 19, 20 and 21LTS (proposal)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Tiki-devel] PHP 7.1 as a minimum requirement for Tiki 19, 20 and 21LTS (proposal)

Marc Laporte-3
Hi!

We don't need to decide now but I think we should at least start the
discussion. This affects workflows (for backports, server upgrades,
etc.) so it’s best to announce it in advance so everyone can plan
accordingly. And if / when people express concerns later, we can point
to a previous discussion and explain why something was done/ decided
and that they had ample time to prepare.

In October or November 2017, we should decide what will be minimum
requirements for
Tiki 19: planned for April 2018
Tiki 20: planned for October 2018
Tiki 21: planned for April 2019

Given:

1- PHP 5.6 and 7.0 will both have security support until Dec 2018
http://php.net/supported-versions.php

2- Zend Framework is moving to PHP 7.1
https://framework.zend.com/blog/2017-06-06-zf-php-7-1.html (Thank you
Ricardo for pointing out this article)

3- The post-LTS release (7, 10, 13, 16) is the ideal time to increase
requirements. This is what was done in the past:
https://doc.tiki.org/Requirements
As Brendan wrote "I also think changing the php requirements mid STL
is bad manners. Some people are going to have php constraints and it
would be super mean to have someone install, configure and launch a
Tiki site (without the ability to downgrade) and then be stuck on
something that doesn’t have security support"

4- We want to innovate:
a) We want to use the latest features of the language
b) Holding developers back to support many versions is time taken away
from adding and improving features.


I think it's best that we set the requirements for 19-20-21 and use
the latest and greatest.

This whole discussion is a recurring theme. This is what I wrote 3
years ago about PHP 5.5 vs 5.4:
https://tiki.org/forumthread52703#threadId53177

"At that time, we didn’t know what RHEL 7 would ship with (or even its
release date). For all we knew, it could have been released 1 year
later. It’s quite a challenge to have a predictable lifecycle
(https://info.tiki.org/Version+Lifecycle) when fundamental components
of the ecosystem don’t. I wish PHP would offer LTS versions and for
RHEL to have a predictable lifecycle like Ubuntu (RHEL is great about
announcing how long a version is supported, but when will RHEL 8 be
released?)"

3 years later, we have the same general challenges. The good news (for
us) is that PHP 7.x vs 5.x is a much smoother transition than Python 3
vs 2. So most distros have to offer Python 2 and 3 in parallel...


I am very much aware that:
a) RHEL 7 ships with PHP 5.4, and we have no due date for RHEL 8 and
no idea what version of PHP will be in it.
b) RHEL software collections have PHP 7.0 but not 7.1
https://www.softwarecollections.org/en/scls/rhscl/rh-php70/
c) The latest released version of Ubuntu ships with PHP 7.0:
https://distrowatch.com/table.php?distribution=ubuntu&pkglist=true&version=17.04#pkglist
d) Debian testing and unstable are still with 7.0:
https://distrowatch.com/table.php?distribution=debian
e) ClearOS just added a PHP version picker with 5.6 and 7.0 but not 7.1:
http://wikisuite.org/How-to-install-a-PHP-version-picker-on-ClearOS


But I am hopeful this will be better by the time Tiki 19.0 is released
in April 2018  If not, some sites will have to stay longer on
Tiki18LTS (which will be a fantastic release) even once Tiki19 is
released. I am convinced PHP 7.1 (first released in Dec 2016) will be
easily and widely available by Tiki 20 (October 2018)




Developers: Please start thinking about making sure your dev tools and
server infrastructure are ready.

Infrastructure team:  This means the pre-dogfood servers should be
running PHP 7.1 in October or November 2017. They are now on PHP 5.6.
Ideally, all the pre-dogfood servers for *.tiki.org sites which are
running 17.x should move now to PHP 7.x so that we try to make Tiki 18
LTS support both PHP 5.6 and 7.0
https://tiki.org/Pre-Dogfood+Server

And all active community members should also move to PHP 7.x ASAP to
help make Tiki 18 LTS support both PHP 5.6 and 7.0

Best regards,


--
Marc Laporte

http://WikiSuite.org
http://PluginProblems.com
http://Avan.Tech

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] PHP 7.1 as a minimum requirement for Tiki 19, 20 and 21LTS (proposal)

Torsten Fabricius-5
Re: PHP 7.1 as a minimum requirement for Tiki 19, 20 and 21LTS (proposal)

Author: Marc Laporte

PHP 7.2 will be released in November 2017:
https://wiki.php.net/todo/php72

And Tiki 19 development will start in December 2017.

So Tiki 19-20-21LTS could require PHP 7.2

This would cause some initial discomfort because PHP 7.2 won't be very available at first. But on the long term, it would permit to take advantage of enhancements of PHP 7.2 and longer support period (compared to PHP 7.1)

Best regards,

M :-)

--
Reply Link: <https://tiki.org//tiki-view_forum_thread.php?forumId=26&comments_reply_threadId=65966&comments_parentId=65966&post_reply=1#form>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Loading...