[Tiki-devel] MySQL Versions

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Tiki-devel] MySQL Versions

Dr. Sassafras
This might be a good time to talk about MySQL version requirements. Right now it's stated that MySQL 5.0 + will work. Is this something that we are testing? I've seen a few commits that fix issues on MySQL 5.7. Are those being backported into security only releases? If not, should there not be a upper MySQL limit placed on earlier tiki versions?

I've also found myself not taking advantage of newer MySQL features because they were introduced post 5.0.

MySQL 5.5 is currently the oldest MySQL version under support, introduced in 2010, MySQL 5.0 was introduced in 2005.

I also still see code in tiki that checks if information_schema is available and reports that the MySQL version didn't support it. Might be nice to clean up some of that code. Information_schema is available in all 5.0+ versions.

I know we've made good progress (I think jonny coded it if I remember correctly) in introducing upper php limit checks in the installer. Perhaps we should introduce similar MySQL checks, even if it's just a warning that's issued.

For tiki 18, I propose 5.5 being the oldest MySQL version supported (if not 5.6), and 5.7 being the upper limit.

I would also propose that all future versions of tiki place a lower and upper MySQL version on them. It will give us a better idea of coding practises and also testing limits as well.

Thoughts?

Brendan
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Tiki-devel] MySQL Versions

Jonny Bradley-4
Hi Brendan

Good point, afraid i don't know but i'm pretty sure no one's really testing (anything much) these days.

I was also thinking we need to make a note about maximum php version too, which i think goes:

* up to 15.x maximum php 5.6
*       16.x maximum php 7.0
*       17.x maximum php 7.1

jb


> On 28 Jun 2017, at 00:03, Dr. Sassafras <[hidden email]> wrote:
>
> This might be a good time to talk about MySQL version requirements. Right now it's stated that MySQL 5.0 + will work. Is this something that we are testing? I've seen a few commits that fix issues on MySQL 5.7. Are those being backported into security only releases? If not, should there not be a upper MySQL limit placed on earlier tiki versions?
>
> I've also found myself not taking advantage of newer MySQL features because they were introduced post 5.0.
>
> MySQL 5.5 is currently the oldest MySQL version under support, introduced in 2010, MySQL 5.0 was introduced in 2005.
>
> I also still see code in tiki that checks if information_schema is available and reports that the MySQL version didn't support it. Might be nice to clean up some of that code. Information_schema is available in all 5.0+ versions.
>
> I know we've made good progress (I think jonny coded it if I remember correctly) in introducing upper php limit checks in the installer. Perhaps we should introduce similar MySQL checks, even if it's just a warning that's issued.
>
> For tiki 18, I propose 5.5 being the oldest MySQL version supported (if not 5.6), and 5.7 being the upper limit.
>
> I would also propose that all future versions of tiki place a lower and upper MySQL version on them. It will give us a better idea of coding practises and also testing limits as well.
>
> Thoughts?
>
> Brendan
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Tiki-devel] MySQL Versions

Cloutier, Philippe (DGARI-Consultant)
In reply to this post by Dr. Sassafras
Hi Brendan,

> -----Message d'origine-----
> De : Dr. Sassafras [mailto:[hidden email]]
> Envoyé : 27 juin 2017 19:04
> À : [hidden email]
> Objet : [Tiki-devel] MySQL Versions
>
> This might be a good time to talk about MySQL version requirements. Right now it's stated that MySQL
> 5.0 + will work. Is this something that we are testing?

We are certainly testing with a MySQL 5.0+ server, but not all :-)
I don't think we have any kind of methodic testing.

> I've seen a few commits that fix issues on MySQL
> 5.7. Are those being backported into security only releases?

I suppose you mean bugfix-only releases. I think backporting there is fine, but if it was me, I would not backport.

> If not, should there not be a upper MySQL
> limit placed on earlier tiki versions?

Yes

>
> I've also found myself not taking advantage of newer MySQL features because they were introduced
> post 5.0.
>
> MySQL 5.5 is currently the oldest MySQL version under support, introduced in 2010, MySQL 5.0 was
> introduced in 2005.
>
> I also still see code in tiki that checks if information_schema is available and reports that the MySQL
> version didn't support it. Might be nice to clean up some of that code. Information_schema is available
> in all 5.0+ versions.
>
> I know we've made good progress (I think jonny coded it if I remember correctly) in introducing upper
> php limit checks in the installer. Perhaps we should introduce similar MySQL checks, even if it's just a
> warning that's issued.
>
> For tiki 18, I propose 5.5 being the oldest MySQL version supported (if not 5.6), and 5.7 being the
> upper limit.

I am not clear on differences between 5.5 and 5.0. I have not been limited but I did not do SQL recently. 5.0 does sound unreasonably old. I certainly have no strong opposition to requiring 5.5, but we need to remain compatible with MariaDB.

As for the upper limit, that should be the highest stable version(s) which we have tested enough. It would be good to create a MySQL (or perhaps "Database" to be more generic) page on dev.tiki.org to track how much testing new versions receive. I am developing with MariaDB 10.1.

>
> I would also propose that all future versions of tiki place a lower and upper MySQL version on them. It
> will give us a better idea of coding practises and also testing limits as well.

I fully support that, as long as it is easy to avoid the upper limit.

>
> Thoughts?
>
> Brendan
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel