Quantcast

[Tiki-devel] Help to debug/document how to use 'Force users to fill tracker information'

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Tiki-devel] Help to debug/document how to use 'Force users to fill tracker information'

Xavier de Pedro (Tiki)

Hi Nelson and Patrick:

Last week I noticed (when exposing new features from Tiki 16 to the update wizard) that this feature "Force users to fill tracker information" was introduced by you quite a while ago, and it linked to a documentation page in doc.t.o which doesn't exist yet.

Now I see that there is a bug report against that feature (see below), which might be affected by the lack of documentation.

Can you please drop a few lines in the corresponding new page in doc.t.o about this feature?

Similarly, we would appreciate if you can demonstrate that PluginChartJS works, since I haven't seen any one succeeding at all to make it show anything (and I know more than 3 people which tried insistently).

Thanks!

Xavi


-------- Forwarded Message --------
Subject: "Bugs & Wish list" item "Pref. Force users to fill tracker information brakes Tiki (seen in 16)" was modified at dev.tiki.org by "Torsten Fabricius"
Date: Sun, 22 Jan 2017 00:40:28 +0100
From: [hidden email]
To: [hidden email]


Item Modification

Tracker:
   Bugs & Wish list
Item:
   6256 Pref. Force users to fill tracker information brakes Tiki (seen in 16)

View the tracker item at:
	https://dev.tiki.org/item6256

Author: Torsten Fabricius
Date:  22 Jan 17 00:40 CET

Status: Open
----------
[Description]:
-Old-:
> The preference "Force users to fill tracker information" in the tiki admin secton "login" broke a newly installed Tiki 16 (from svn) shortly after installation, at the moment of activation.> > I just have had started the configuration.  Trackers was not yet active, so not User Tracker aswell. I will activate Trackers and User Tracker prior to activate the preference in the show instance.> > This is the error message I had after activation, representing a full WSOD for logged in admin > (Please mind: the anonymous user still could see the website):> > {CODE()}> Fatal error: Call to a member function getUserField() on boolean in /www/htdocs/.../tiki/.../currentroot/lib/setup/tracker_force_fill.php on line 18> {CODE}> > __Update:__> When I first setup Tacker and User Tracker in the show instance, the "Force users to fill tracker information" continuously forces users to again and again create a new tracker item, even when multiple exist.> Try now with autouser field.> >
  _
_Update2:__> User field with auto assign helped, but Tracker is creating multiple items, when updating info. Obviously I forgot to set "only one tem per user"! ...> > 

*New*:
The preference "Force users to fill tracker information" in the tiki admin secton "login" broke a newly installed Tiki 16 (from svn) shortly after installation, at the moment of activation.

I just have had started the configuration.  Trackers was not yet active, so not User Tracker aswell. I will activate Trackers and User Tracker prior to activate the preference in the show instance.

This is the error message I had after activation, representing a full WSOD for logged in admin 
(Please mind: the anonymous user still could see the website):

{CODE()}
Fatal error: Call to a member function getUserField() on boolean in /www/htdocs/.../tiki/.../currentroot/lib/setup/tracker_force_fill.php on line 18
{CODE}

__Update:__
When I first setup Tacker and User Tracker in the show instance, the "Force users to fill tracker information" continuously forces users to again and again create a new tracker item, even when multiple exist.
Try now with autouser field.

__Update2:__
User field with auto assign helped, but Tracker is creating multiple items, when updating info. Obviously I forgot to set "only one tem per user"! ...

__Update3:__ 
It is NOT working correctly. When updating user data (in tracker) from the 'my Account' -> 'my info' -> 'Additional Information' tab, multiple Tracker items are created.


----------





------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Help to debug/document how to use 'Force users to fill tracker information'

Nelson Ko-4
Hi - pretty swamped at the moment with imminent site launch. Will get back to this in a week or so.

On Mon, Jan 23, 2017 at 9:23 AM, Xavier de Pedro <[hidden email]> wrote:

Hi Nelson and Patrick:

Last week I noticed (when exposing new features from Tiki 16 to the update wizard) that this feature "Force users to fill tracker information" was introduced by you quite a while ago, and it linked to a documentation page in doc.t.o which doesn't exist yet.

Now I see that there is a bug report against that feature (see below), which might be affected by the lack of documentation.

Can you please drop a few lines in the corresponding new page in doc.t.o about this feature?

Similarly, we would appreciate if you can demonstrate that PluginChartJS works, since I haven't seen any one succeeding at all to make it show anything (and I know more than 3 people which tried insistently).

Thanks!

Xavi


-------- Forwarded Message --------
Subject: "Bugs & Wish list" item "Pref. Force users to fill tracker information brakes Tiki (seen in 16)" was modified at dev.tiki.org by "Torsten Fabricius"
Date: Sun, 22 Jan 2017 00:40:28 +0100
From: [hidden email]
To: [hidden email]


Item Modification

Tracker:
   Bugs & Wish list
Item:
   6256 Pref. Force users to fill tracker information brakes Tiki (seen in 16)

View the tracker item at:
	https://dev.tiki.org/item6256

Author: Torsten Fabricius
Date:  22 Jan 17 00:40 CET

Status: Open
----------
[Description]:
-Old-:
> The preference "Force users to fill tracker information" in the tiki admin secton "login" broke a newly installed Tiki 16 (from svn) shortly after installation, at the moment of activation.> > I just have had started the configuration.  Trackers was not yet active, so not User Tracker aswell. I will activate Trackers and User Tracker prior to activate the preference in the show instance.> > This is the error message I had after activation, representing a full WSOD for logged in admin > (Please mind: the anonymous user still could see the website):> > {CODE()}> Fatal error: Call to a member function getUserField() on boolean in /www/htdocs/.../tiki/.../currentroot/lib/setup/tracker_force_fill.php on line 18> {CODE}> > __Update:__> When I first setup Tacker and User Tracker in the show instance, the "Force users to fill tracker information" continuously forces users to again and again create a new tracker item, even when multiple exist.> Try now with autouser field.> >
  _
_Update2:__> User field with auto assign helped, but Tracker is creating multiple items, when updating info. Obviously I forgot to set "only one tem per user"! ...> > 

*New*:
The preference "Force users to fill tracker information" in the tiki admin secton "login" broke a newly installed Tiki 16 (from svn) shortly after installation, at the moment of activation.

I just have had started the configuration.  Trackers was not yet active, so not User Tracker aswell. I will activate Trackers and User Tracker prior to activate the preference in the show instance.

This is the error message I had after activation, representing a full WSOD for logged in admin 
(Please mind: the anonymous user still could see the website):

{CODE()}
Fatal error: Call to a member function getUserField() on boolean in /www/htdocs/.../tiki/.../currentroot/lib/setup/tracker_force_fill.php on line 18
{CODE}

__Update:__
When I first setup Tacker and User Tracker in the show instance, the "Force users to fill tracker information" continuously forces users to again and again create a new tracker item, even when multiple exist.
Try now with autouser field.

__Update2:__
User field with auto assign helped, but Tracker is creating multiple items, when updating info. Obviously I forgot to set "only one tem per user"! ...

__Update3:__ 
It is NOT working correctly. When updating user data (in tracker) from the 'my Account' -> 'my info' -> 'Additional Information' tab, multiple Tracker items are created.


----------






------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Loading...