Quantcast

[Tiki-devel] Fatal error using webmail in 16.2

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Tiki-devel] Fatal error using webmail in 16.2

Geoff - Enmore Services

Hi – I’m building a new site with Tiki16.2 and I’ve just hit a fatal error with webmail that I can’t really understand:

 

Fatal error: Cannot use object of type Zend\Mail\Headers as array in /xxx/xxx/makerspace.marlborougharea.org/lib/webmail/webmaillib.php on line 449

 

 

This occurred when I set up an IMAP account in webmail and sent a test mail that I copied back to the sending address – immediately after I sent the mail I clicked the Mailbox to check that that part of the account set up was OK ie it was receiving – and that’s when I got the fatal error. The test mail was sent fine. The error keeps re-occurring until the sent email has been collected by another client i.e. the remote mailbox is emptied and then the webmail Mailbox function shows the normal screen but with the table empty – so there is something wrong in the collection/reading part of webmail

 

Anyone got any suggestions?

 

geoff

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2016.0.7998 / Virus Database: 4756/13961 - Release Date: 02/16/17


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Fatal error using webmail in 16.2

Jonny Bradley-4
Hi Geoff

Long time no Tiki? :)

Yes, it looks like that hasn't been checked since the move to ZF2 - i fixed a bit of it locally but am out of time now and found other not so good (non-php7) stuff.

Another one for the list! :)

jb





On 16 Feb 2017, at 22:50, Geoff - Enmore Services <[hidden email]> wrote:

Hi – I’m building a new site with Tiki16.2 and I’ve just hit a fatal error with webmail that I can’t really understand:
 
Fatal error: Cannot use object of type Zend\Mail\Headers as array in /xxx/xxx/makerspace.marlborougharea.org/lib/webmail/webmaillib.php on line 449
 
 
This occurred when I set up an IMAP account in webmail and sent a test mail that I copied back to the sending address – immediately after I sent the mail I clicked the Mailbox to check that that part of the account set up was OK ie it was receiving – and that’s when I got the fatal error. The test mail was sent fine. The error keeps re-occurring until the sent email has been collected by another client i.e. the remote mailbox is emptied and then the webmail Mailbox function shows the normal screen but with the table empty – so there is something wrong in the collection/reading part of webmail
 
Anyone got any suggestions?
 
geoff

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2016.0.7998 / Virus Database: 4756/13961 - Release Date: 02/16/17

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Fatal error using webmail in 16.2

Geoff - Enmore Services
In reply to this post by Geoff - Enmore Services

Hi Jonny – you are, as always, a star!!

 

Just the webmail feedback for now:

 

In trunk: The first problem of the fatal error when trying to see the summary of emails in the webmail Inbox is sorted, but now getting the following fatal error when trying to ‘fully’ read the received email ie clicking the Full headers option:

 

 

Fatal error: Uncaught Zend\Mail\Protocol\Exception\RuntimeException: the single id was not found in response in /xxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Protocol/Imap.php:615 Stack trace: #0 /xxxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Storage/Imap.php(120): Zend\Mail\Protocol\Imap->fetch(Array, '') #1 /xxxxx/opendev4.enmoreservices.com/tiki-webmail.php(132): Zend\Mail\Storage\Imap->getMessage('') #2 {main} thrown in /xxxxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Protocol/Imap.php on line 615

 

 

BUT:  getting the same/similar error in Tiki12 ie

 

Fatal error: Uncaught exception 'Zend_Mail_Protocol_Exception' with message 'the single id was not found in response' in /xxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Protocol/Imap.php:633 Stack trace: #0 /xxxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Storage/Imap.php(165): Zend_Mail_Protocol_Imap->fetch(Array, '') #1 /xxxxx/opendev.enmoreservices.com/tiki-webmail.php(132): Zend_Mail_Storage_Imap->getMessage('') #2 {main} thrown in /xxxxxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Protocol/Imap.php on line 633

 

 

Which suggests that this additional error may not be related to the ZF2 move?? Did we upgrade Tiki12 to ZF2 as well??

 

g

 

 

 

From: Jonny Bradley [mailto:[hidden email]]
Sent: 18 February 2017 15:39
To: Tiki developers <[hidden email]>
Subject: Re: [Tiki-devel] Fatal error using webmail in 16.2 - and a few more 16.2 'irritants'

 

Hi Geoff

 

On 18 Feb 2017, at 14:15, Geoff - Enmore Services <[hidden email]> wrote:

 

Thanks Jonny – yep back into a bit of a Tiki push to move my Tiki12 sites through to Bootstrap and at least Tiki15 

 

So, an enabling project for this is this new Tiki16 deployment where I’m aiming to check out as much of ‘my stuff’ as possible i.e. all the various special (and perhaps you might think odd!!) ways that I’ve developed over the years.

 

This ZF2 migration fatal error is the only biggy I’ve tripped over so far, but I’ve also just found a couple of what I would call ‘irritants’.

 

Hopefully all fixed in r61330 in trunk, can you test in that before we backport in case i missed any (mostly it was the headers now are Capitalised instead of lowercase)



 

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2016.0.7998 / Virus Database: 4756/13975 - Release Date: 02/19/17


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Tiki-devel] Fatal error using webmail in 16.2

Jonny Bradley-4

Curious, i'm also getting that one, but wasn't yesterday... ah, this seems to happen now if you have a magic that cannot be found, seems a little extreme to throw an exception, but i've added a try/catch for it that seems to work, just vcan't commit as sf.net is offline :(

jb





> On 19 Feb 2017, at 08:29, Geoff - Enmore Services <[hidden email]> wrote:
>
> Hi Jonny – you are, as always, a star!!
>  
> Just the webmail feedback for now:
>  
> In trunk: The first problem of the fatal error when trying to see the summary of emails in the webmail Inbox is sorted, but now getting the following fatal error when trying to ‘fully’ read the received email ie clicking the Full headers option:
>  
>  
> Fatal error: Uncaught Zend\Mail\Protocol\Exception\RuntimeException: the single id was not found in response in /xxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Protocol/Imap.php:615 Stack trace: #0 /xxxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Storage/Imap.php(120): Zend\Mail\Protocol\Imap->fetch(Array, '') #1 /xxxxx/opendev4.enmoreservices.com/tiki-webmail.php(132): Zend\Mail\Storage\Imap->getMessage('') #2 {main} thrown in /xxxxxx/opendev4.enmoreservices.com/vendor/zendframework/zend-mail/src/Protocol/Imap.php on line 615
>  
>  
> BUT:  getting the same/similar error in Tiki12 ie
>  
> Fatal error: Uncaught exception 'Zend_Mail_Protocol_Exception' with message 'the single id was not found in response' in /xxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Protocol/Imap.php:633 Stack trace: #0 /xxxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Storage/Imap.php(165): Zend_Mail_Protocol_Imap->fetch(Array, '') #1 /xxxxx/opendev.enmoreservices.com/tiki-webmail.php(132): Zend_Mail_Storage_Imap->getMessage('') #2 {main} thrown in /xxxxxx/opendev.enmoreservices.com/vendor/bombayworks/zendframework1/library/Zend/Mail/Protocol/Imap.php on line 633
>  
>  
> Which suggests that this additional error may not be related to the ZF2 move?? Did we upgrade Tiki12 to ZF2 as well??
>  
> g
>  
>  
>  
> From: Jonny Bradley [mailto:[hidden email]]
> Sent: 18 February 2017 15:39
> To: Tiki developers <[hidden email]>
> Subject: Re: [Tiki-devel] Fatal error using webmail in 16.2 - and a few more 16.2 'irritants'
>  
> Hi Geoff
>  
>> On 18 Feb 2017, at 14:15, Geoff - Enmore Services <[hidden email]> wrote:
>>  
>> Thanks Jonny – yep back into a bit of a Tiki push to move my Tiki12 sites through to Bootstrap and at least Tiki15
>>  
>> So, an enabling project for this is this new Tiki16 deployment where I’m aiming to check out as much of ‘my stuff’ as possible i.e. all the various special (and perhaps you might think odd!!) ways that I’ve developed over the years.
>>  
>> This ZF2 migration fatal error is the only biggy I’ve tripped over so far, but I’ve also just found a couple of what I would call ‘irritants’.
>  
> Hopefully all fixed in r61330 in trunk, can you test in that before we backport in case i missed any (mostly it was the headers now are Capitalised instead of lowercase)
>
>
>  
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2016.0.7998 / Virus Database: 4756/13975 - Release Date: 02/19/17
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot_______________________________________________
> TikiWiki-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
Loading...