Mail notifications don't work post 1.8.5->1.9.0 upgrade

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
Hi,

[I posted this to the forums as well, but I guess there'll be a wider
audience here]

I upgraded from 1.8.5 to 1.9.0 and the configured mail notifications
(for 'any wiki page changes', send mail to some list) don't work
anymore.

Also, after editing a page and saving it, it just shows a blank page
in the browser. On a manual refresh, it goes back to the edited page.
I don't know if these two are related, but they could be.

Any suggestions on any of these two problems?

Thanks,
Amit.
--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Damian Parker
On Tue, May 17, 2005 at 04:46:07PM +0530, Amit Shah wrote:

> Hi,
>
> [I posted this to the forums as well, but I guess there'll be a wider
> audience here]
>
> I upgraded from 1.8.5 to 1.9.0 and the configured mail notifications
> (for 'any wiki page changes', send mail to some list) don't work
> anymore.
>
> Also, after editing a page and saving it, it just shows a blank page
> in the browser. On a manual refresh, it goes back to the edited page.
> I don't know if these two are related, but they could be.
>
> Any suggestions on any of these two problems?


Probably related: http://tikiwiki.org/art82  PHP memory_limit set
to 8Mb, TikiWiki needs more memory.

--


Damian Parker
Damosoft - TikiWiki Support, Development and Training
http://www.damosoft.co.uk / http://tikihost.net / http://tikiwiki.info
Telephone - 0845 004 3923  IAXtel - 700-168-0333  FWD - 72453
Full Online Support Tracking at - http://support.damosoft.net


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
Hi Damian,

On 5/17/05, Damian Parker <[hidden email]> wrote:
> On Tue, May 17, 2005 at 04:46:07PM +0530, Amit Shah wrote:
> > Hi,

> > I upgraded from 1.8.5 to 1.9.0 and the configured mail notifications
> > (for 'any wiki page changes', send mail to some list) don't work
> > anymore.
> >
> > Also, after editing a page and saving it, it just shows a blank page
> > in the browser. On a manual refresh, it goes back to the edited page.
> > I don't know if these two are related, but they could be.
> >
> > Any suggestions on any of these two problems?
>
> Probably related: http://tikiwiki.org/art82  PHP memory_limit set
> to 8Mb, TikiWiki needs more memory.

I already have it to 32MB. That doesn't seem to be the problem here.

Amit.

--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Marc Laporte
In reply to this post by shahamit (Bugzilla)
I have noticed that mail notifications are unreliable.

I could not duplicate the problem but I suspect something like : when
you change the name of a page, the watch settings do not follow.

M ;-)




Amit Shah wrote:

>Hi,
>
>[I posted this to the forums as well, but I guess there'll be a wider
>audience here]
>
>I upgraded from 1.8.5 to 1.9.0 and the configured mail notifications
>(for 'any wiki page changes', send mail to some list) don't work
>anymore.
>
>Also, after editing a page and saving it, it just shows a blank page
>in the browser. On a manual refresh, it goes back to the edited page.
>I don't know if these two are related, but they could be.
>
>Any suggestions on any of these two problems?
>
>Thanks,
>Amit.
>  
>

--
M ;-)

//////////////////////////////////////////////////////////////////
/                                                                /
/ Marc Laporte       <|>                  http://marclaporte.com /
/ Avantech.net       <|>                     http://avantech.net /
/ Tiki CMS/Groupware <|> http://tikiwiki.org/UserPagemarclaporte /
/                                                                /
//////////////////////////////////////////////////////////////////



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
On 5/17/05, Marc Laporte <[hidden email]> wrote:
> I have noticed that mail notifications are unreliable.
>
> I could not duplicate the problem but I suspect something like : when
> you change the name of a page, the watch settings do not follow.

But I've not changed them... just an upgrade and change some pages.
The notifications worked earlier, they don't work now..

>
> M ;-)

Amit

--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Marc Laporte
I wrote "something like". If I knew what it was, I would have filed a
bug report on dev.tikiwiki.org ;-)

M ;-)

Amit Shah wrote:

>On 5/17/05, Marc Laporte <[hidden email]> wrote:
>  
>
>>I have noticed that mail notifications are unreliable.
>>
>>I could not duplicate the problem but I suspect something like : when
>>you change the name of a page, the watch settings do not follow.
>>    
>>
>
>But I've not changed them... just an upgrade and change some pages.
>The notifications worked earlier, they don't work now..
>
>  
>
>>M ;-)
>>    
>>
>
>Amit
>
>  
>

--
M ;-)

//////////////////////////////////////////////////////////////////
/                                                                /
/ Marc Laporte       <|>                  http://marclaporte.com /
/ Avantech.net       <|>                     http://avantech.net /
/ Tiki CMS/Groupware <|> http://tikiwiki.org/UserPagemarclaporte /
/                                                                /
//////////////////////////////////////////////////////////////////



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Sylvie Greverend
In reply to this post by shahamit (Bugzilla)

Are your php error on... Perhaps the blank page is an error (in the mail
notification)??

> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]]On Behalf Of Amit
> Shah
> Sent: Tuesday, May 17, 2005 7:58 AM
> To: [hidden email]
> Subject: Re: [Tikiwiki-users] Mail notifications don't work post
> 1.8.5->1.9.0 upgrade
>
>
> On 5/17/05, Marc Laporte <[hidden email]> wrote:
> > I have noticed that mail notifications are unreliable.
> >
> > I could not duplicate the problem but I suspect something like : when
> > you change the name of a page, the watch settings do not follow.
>
> But I've not changed them... just an upgrade and change some pages.
> The notifications worked earlier, they don't work now..
>
> >
> > M ;-)
>
> Amit
>
> --
> Amit Shah
> http://www.livejournal.com/users/amitshah/
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> <a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick">http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick
> _______________________________________________
> Tikiwiki-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>




-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
On 5/17/05, Sylvie Greverend <[hidden email]> wrote:
>
> Are your php error on... Perhaps the blank page is an error (in the mail
> notification)??

Yeah, the php error notifications are on, I don't get any errors though.

Amit.
--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
I got this error message now:

Fatal error: Smarty error: [in mail/user_watch_wiki_page_changed.tpl
line 34]: [plugin] modifier 'html_entity_decode' is not implemented
(core.load_plugins.php, line 118) in
/var/www/html/tiki/lib/smarty/libs/Smarty.class.php on line 1088

Does this help?

--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Sylvie Greverend
html_entity_decode exists only in php4. I suppose you have phph3?

I suppose you can take away (a tempororary solution - a html change will be
incorrectly displayed) all the "|html_entity_decode" in
templates/mail/user_watch_wiki_page_changed.tpl

reverse back
http://cvs.sourceforge.net/viewcvs.py/tikiwiki/tiki/templates/mail/user_watc
h_wiki_page_changed.tpl?r1=1.8.2.3&r2=1.8.2.4



> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]]On Behalf Of Amit
> Shah
> Sent: Friday, May 20, 2005 6:44 AM
> To: [hidden email]
> Subject: Re: [Tikiwiki-users] Mail notifications don't work post
> 1.8.5->1.9.0 upgrade
>
>
> I got this error message now:
>
> Fatal error: Smarty error: [in mail/user_watch_wiki_page_changed.tpl
> line 34]: [plugin] modifier 'html_entity_decode' is not implemented
> (core.load_plugins.php, line 118) in
> /var/www/html/tiki/lib/smarty/libs/Smarty.class.php on line 1088
>
> Does this help?
>
> --
> Amit Shah
> http://www.livejournal.com/users/amitshah/
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> <a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick">http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick
> _______________________________________________
> Tikiwiki-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>




-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

shahamit (Bugzilla)
On 5/20/05, Sylvie Greverend <[hidden email]> wrote:
> html_entity_decode exists only in php4. I suppose you have phph3?
>
> I suppose you can take away (a tempororary solution - a html change will be
> incorrectly displayed) all the "|html_entity_decode" in
> templates/mail/user_watch_wiki_page_changed.tpl
>
> reverse back
> http://cvs.sourceforge.net/viewcvs.py/tikiwiki/tiki/templates/mail/user_watc
> h_wiki_page_changed.tpl?r1=1.8.2.3&r2=1.8.2.4

I have php 4.2.2-17 (RHL8.0). Reverting this patch does help.

Thanks,
Amit.

--
Amit Shah
http://www.livejournal.com/users/amitshah/


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Xavier de Pedro Puente
In reply to this post by Sylvie Greverend
Hi Sylvie and Amit,

Can this be related to another recent (1.9.0) smarty error that some
people are finding with the catalan translation?

It seems to be related with not escping properly apostrophes/single
quotes  (') in the updated .tpl's (in our cases the problems are mainly
in tiki-show_page.tpl).

Related bug reports:

problem with single quotes in some translated text
http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=189&show=view&status=op&trackerId=5&sort_mode=created_desc

i18n-related smarty error on a brand new 1.9.0 ...
http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=191&show=view&status=op&trackerId=5&sort_mode=f_41_desc&filterfield=54&filtervalue[54]=xavidp

homepage on dev.tw.o not displayed to me: missing l10n-specific content
in my browser lang?
http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=181&show=view&status=op&trackerId=5&sort_mode=f_41_desc&filterfield=54&filtervalue[54]=xavidp

Cheers,

Xavi

En/na Sylvie Greverend ha escrit:

>html_entity_decode exists only in php4. I suppose you have phph3?
>
>I suppose you can take away (a tempororary solution - a html change will be
>incorrectly displayed) all the "|html_entity_decode" in
>templates/mail/user_watch_wiki_page_changed.tpl
>
>reverse back
>http://cvs.sourceforge.net/viewcvs.py/tikiwiki/tiki/templates/mail/user_watc
>h_wiki_page_changed.tpl?r1=1.8.2.3&r2=1.8.2.4
>
>
>
>  
>
>>-----Original Message-----
>>From: [hidden email]
>>[mailto:[hidden email]]On Behalf Of Amit
>>Shah
>>Sent: Friday, May 20, 2005 6:44 AM
>>To: [hidden email]
>>Subject: Re: [Tikiwiki-users] Mail notifications don't work post
>>1.8.5->1.9.0 upgrade
>>
>>
>>I got this error message now:
>>
>>Fatal error: Smarty error: [in mail/user_watch_wiki_page_changed.tpl
>>line 34]: [plugin] modifier 'html_entity_decode' is not implemented
>>(core.load_plugins.php, line 118) in
>>/var/www/html/tiki/lib/smarty/libs/Smarty.class.php on line 1088
>>
>>Does this help?
>>
>>--
>>Amit Shah
>>http://www.livejournal.com/users/amitshah/
>>
>>
>>-------------------------------------------------------
>>This SF.Net email is sponsored by Oracle Space Sweepstakes
>>Want to be the first software developer in space?
>>Enter now for the Oracle Space Sweepstakes!
>><a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick">http://ads.osdn.com/?ad_idt12&alloc_id344&op=ick
>>_______________________________________________
>>Tikiwiki-users mailing list
>>[hidden email]
>>https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>>
>>    
>>
>
>
>
>
>-------------------------------------------------------
>This SF.Net email is sponsored by Oracle Space Sweepstakes
>Want to be the first software developer in space?
>Enter now for the Oracle Space Sweepstakes!
>http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
>_______________________________________________
>Tikiwiki-users mailing list
>[hidden email]
>https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>
>
>  
>

--

============================
Xavier de Pedro Puente
Departament d'Ecologia
Universitat de Barcelona
Avda. Diagonal 645. 08028 Barcelona
Tel. 93 4021508 // Fax. 93 4111438
[hidden email] // [hidden email]
http://www.ub.edu/ecolo
---
http://gclub.ub.es - Grup pel Coneixement lliure a la UB (gclub)
http://uniwiki.ourproject.org - Projecte UniWiki d'innovaci√≥ docent



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
<a href="http://ads.osdn.com/?ad_idt12&alloc_id344&op=click">http://ads.osdn.com/?ad_idt12&alloc_id344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Mail notifications don't work post 1.8.5->1.9.0 upgrade

Sylvie Greverend

> problem with single quotes in some translated text
> http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=189&show
> =view&status=op&trackerId=5&sort_mode=created_desc
No, this is a generic problem. All {tr}s must be surrounded with "" .. The
translation is easier. (I added the rule in
http://tikiwiki.org/tiki-index.php?page=TikiWikiInternationalizationAndLangu
ages).
Welcome to everyone that wants to change it in the tpl. I fixed for
tiki-show_page.tpl.
Another approach is to use &quot; in the translated string but the
translation job is enough painful like this....

>
> i18n-related smarty error on a brand new 1.9.0 ...
> http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=191&show
> =view&status=op&trackerId=5&sort_mode=f_41_desc&filterfield=54&fil
> tervalue[54]=xavidp
I think it is the same problem tan the previous one

>
> homepage on dev.tw.o not displayed to me: missing l10n-specific content
> in my browser lang?
> http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=181&show
> =view&status=op&trackerId=5&sort_mode=f_41_desc&filterfield=54&fil
> tervalue[54]=xavidp
This is weird! Doesn't seem to be connected to the browser setting, only to
the catalan. The site doesn't the multilingual feature on .... Investigation
going on

>>




-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
_______________________________________________
Tikiwiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Loading...