16.2 tiki-installer fails to recognize the specified database

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

16.2 tiki-installer fails to recognize the specified database

"Tóth Attila"
I'm currently running 16.1 and just tried to upgrade to 16.2 lately. I
usually browse to tiki-install.php, specify database details and select
choose upgrade database. The upgrade from 16.0 to 16.1 went smooth. Now
the installer for 16.2 doesn't seem to recognize the database and asks to
specify it again and again. The setup is simple, the database is on the
same machine and the website is otherwise working using the connection the
installer denies.
The installer says: "Tiki cannot find a database connection."
Several non-tiki websites are working fine as well on the same machine.
The database connection is OK and I can manually access the database at
the mariadb prompt using tiki's credentials. All I can find in the logs
is: "apache2: PHP Notice:  unserialize(): Error at offset 0 of 5 bytes in
/var/www/localhost/htdocs/tikiwiki/lib/setup/prefs.php on line 377".
However it doesn't show up every time it fails to access the database, so
it may be my mistake.
It was a long time before I did a manual upgrade. I followed a link shown
by the installer (php console.php database:install). But it reports
correctly, that the database already exists. I have a feeling this is for
recreating the database.
Any of you run into some problems trying to upgrade tiki?
How I can manually apply database realted changes?
"php console.php -n database:update" right?
I manage the lock file manually, anyways.

Thx:
Dw.
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|

Re: 16.2 tiki-installer fails to recognize the specified database

Bernard Sfez-3
Hi,

Mmm I do a lot of install/upgrade to test version every week.

First make sure you have backup of db and/or duplicate your 161 db to a new db (UTF-8) and proceed on the copy (so your data are safe).
Check that your mysql user can connect and view the db (shell).

Then I would delete the file db/local.php, reload in a browser your tiki (it should goes to to tiki-install.php) and do the all install (not upgrade only).

Enter all the requested db information and go on.

Tell us how it worked.

Cheers
Bernard


On 4 Feb 2017, at 20:39 , Tóth Attila <[hidden email]> wrote:

I'm currently running 16.1 and just tried to upgrade to 16.2 lately. I
usually browse to tiki-install.php, specify database details and select
choose upgrade database. The upgrade from 16.0 to 16.1 went smooth. Now
the installer for 16.2 doesn't seem to recognize the database and asks to
specify it again and again. The setup is simple, the database is on the
same machine and the website is otherwise working using the connection the
installer denies.
The installer says: "Tiki cannot find a database connection."
Several non-tiki websites are working fine as well on the same machine.
The database connection is OK and I can manually access the database at
the mariadb prompt using tiki's credentials. All I can find in the logs
is: "apache2: PHP Notice:  unserialize(): Error at offset 0 of 5 bytes in
/var/www/localhost/htdocs/tikiwiki/lib/setup/prefs.php on line 377".
However it doesn't show up every time it fails to access the database, so
it may be my mistake.
It was a long time before I did a manual upgrade. I followed a link shown
by the installer (php console.php database:install). But it reports
correctly, that the database already exists. I have a feeling this is for
recreating the database.
Any of you run into some problems trying to upgrade tiki?
How I can manually apply database realted changes?
"php console.php -n database:update" right?
I manage the lock file manually, anyways.

Thx:
Dw.
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|

Re: 16.2 tiki-installer fails to recognize the specified database

"Tóth Attila"
Hi Bernard,

I could successfully upgrade the database issuing "php console.php
database:upgrade". The setup is working fine.
I always make a backup before upgrades, so I will also be able to try your
suggesstion later.

Thanks:
Attila
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057

2017.Február 5.(V) 05:58 időpontban Bernard Sfez ezt írta:

> Hi,
>
> Mmm I do a lot of install/upgrade to test version every week.
>
> First make sure you have backup of db and/or duplicate your 161 db to a
> new db (UTF-8) and proceed on the copy (so your data are safe).
> Check that your mysql user can connect and view the db (shell).
>
> Then I would delete the file db/local.php, reload in a browser your tiki
> (it should goes to to tiki-install.php) and do the all install (not
> upgrade only).
>
> Enter all the requested db information and go on.
>
> Tell us how it worked.
>
> Cheers
> Bernard
>
>
>> On 4 Feb 2017, at 20:39 , Tóth Attila <[hidden email]> wrote:
>>
>> I'm currently running 16.1 and just tried to upgrade to 16.2 lately. I
>> usually browse to tiki-install.php, specify database details and select
>> choose upgrade database. The upgrade from 16.0 to 16.1 went smooth. Now
>> the installer for 16.2 doesn't seem to recognize the database and asks
>> to
>> specify it again and again. The setup is simple, the database is on the
>> same machine and the website is otherwise working using the connection
>> the
>> installer denies.
>> The installer says: "Tiki cannot find a database connection."
>> Several non-tiki websites are working fine as well on the same machine.
>> The database connection is OK and I can manually access the database at
>> the mariadb prompt using tiki's credentials. All I can find in the logs
>> is: "apache2: PHP Notice:  unserialize(): Error at offset 0 of 5 bytes
>> in
>> /var/www/localhost/htdocs/tikiwiki/lib/setup/prefs.php on line 377".
>> However it doesn't show up every time it fails to access the database,
>> so
>> it may be my mistake.
>> It was a long time before I did a manual upgrade. I followed a link
>> shown
>> by the installer (php console.php database:install). But it reports
>> correctly, that the database already exists. I have a feeling this is
>> for
>> recreating the database.
>> Any of you run into some problems trying to upgrade tiki?
>> How I can manually apply database realted changes?
>> "php console.php -n database:update" right?
>> I manage the lock file manually, anyways.
>>
>> Thx:
>> Dw.
>> --
>> dr Tóth Attila, Radiológus, 06-20-825-8057
>> Attila Toth MD, Radiologist, +36-20-825-8057
>>
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
>> _______________________________________________
>> TikiWiki-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>
> Bernard Sfez | bsfez.com <https://bsfez.com/>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org!
> http://sdm.link/slashdot_______________________________________________
> TikiWiki-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
Reply | Threaded
Open this post in threaded view
|

Re: 16.2 tiki-installer fails to recognize the specified database

Bernard Sfez-3
;)

If you can

 "php console.php
database:upgrade"

It sound to me that the local.php file contain the right credential to access your db.

May be a "human" error ?
Cause the install script is ok for many other users (I do at least 2 install a day for test and demo) :D

Bernard

On 5 Feb 2017, at 12:45 , Tóth Attila <[hidden email]> wrote:

Hi Bernard,

I could successfully upgrade the database issuing "php console.php
database:upgrade". The setup is working fine.
I always make a backup before upgrades, so I will also be able to try your
suggesstion later.

Thanks:
Attila
-- 
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057

2017.Február 5.(V) 05:58 időpontban Bernard Sfez ezt írta:
Hi,

Mmm I do a lot of install/upgrade to test version every week.

First make sure you have backup of db and/or duplicate your 161 db to a
new db (UTF-8) and proceed on the copy (so your data are safe).
Check that your mysql user can connect and view the db (shell).

Then I would delete the file db/local.php, reload in a browser your tiki
(it should goes to to tiki-install.php) and do the all install (not
upgrade only).

Enter all the requested db information and go on.

Tell us how it worked.

Cheers
Bernard


On 4 Feb 2017, at 20:39 , Tóth Attila <[hidden email]> wrote:

I'm currently running 16.1 and just tried to upgrade to 16.2 lately. I
usually browse to tiki-install.php, specify database details and select
choose upgrade database. The upgrade from 16.0 to 16.1 went smooth. Now
the installer for 16.2 doesn't seem to recognize the database and asks
to
specify it again and again. The setup is simple, the database is on the
same machine and the website is otherwise working using the connection
the
installer denies.
The installer says: "Tiki cannot find a database connection."
Several non-tiki websites are working fine as well on the same machine.
The database connection is OK and I can manually access the database at
the mariadb prompt using tiki's credentials. All I can find in the logs
is: "apache2: PHP Notice:  unserialize(): Error at offset 0 of 5 bytes
in
/var/www/localhost/htdocs/tikiwiki/lib/setup/prefs.php on line 377".
However it doesn't show up every time it fails to access the database,
so
it may be my mistake.
It was a long time before I did a manual upgrade. I followed a link
shown
by the installer (php console.php database:install). But it reports
correctly, that the database already exists. I have a feeling this is
for
recreating the database.
Any of you run into some problems trying to upgrade tiki?
How I can manually apply database realted changes?
"php console.php -n database:update" right?
I manage the lock file manually, anyways.

Thx:
Dw.
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users

Bernard Sfez | bsfez.com <https://bsfez.com/>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org!
http://sdm.link/slashdot_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users

Bernard Sfez | bsfez.com


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
TikiWiki-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users